Service Console seems to be down

Major Incident Console
9 minutes

Update

Resolved

Service is back up.

Sep 12th, 2019 12:07 EDT
Issue

Our monitoring system has found out the service Console is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Sep 12th, 2019 11:58 EDT